Intermittent Sign-in Trouble for Outlook Users
Incident Report for Unroll.Me
Resolved
According to Outlook, everything is back up and running. Thanks for your patience!
Posted 5 months ago. Mar 22, 2017 - 13:26 UTC
Investigating
Because of some ongoing issues with Outlook, users who have Outlook accounts might have intermittent trouble signing into Unroll.Me. They suggest that refreshing the page and trying again, or even just trying again, might work.

You can see Outlook's error page here:

https://portal.office.com/servicestatus

Sorry for the inconvenience!
Posted 5 months ago. Mar 21, 2017 - 18:51 UTC