We experienced issues with sending Rollups this morning
Incident Report for Unroll.Me
Resolved
We have resolved this issue and Rollups have returned to working as normal.
Posted over 1 year ago. Aug 24, 2016 - 18:26 UTC
Investigating
We experienced issues with sending Rollups this morning
Posted over 1 year ago. Aug 24, 2016 - 18:22 UTC