We are investigating issues affecting some Yahoo and AOL mailboxes
Incident Report for Unroll.Me
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 21, 2017 - 18:40 UTC
Update
We are currently in the process of testing the fixes that we have in place.
Posted about 1 year ago. Sep 08, 2016 - 15:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 year ago. Aug 31, 2016 - 18:31 UTC
Investigating
Our team is looking into an elevated rate of failures in Yahoo and AOL accounts. You may be seeing emails arriving directly to your inbox that would normally be intercepted. We're sorry for the inconvenience and appreciate your patience as we work to fix these issues.
Posted about 1 year ago. Aug 30, 2016 - 16:47 UTC